Intermittent access issues affecting Pantheon Dashboard and Workflow

Incident Report for Pantheon Operations

Resolved

This incident has been resolved.
Posted Mar 28, 2026 - 07:30 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2026 - 06:59 PDT

Update

We are continuing to investigate the issue.

We recommend postponing non-critical tasks involving the Dashboard or CLI until the issue is resolved.

If you are unable to access the Dashboard and need urgent support, please contact helpdesk@pantheon.io for support.
Posted Mar 28, 2026 - 06:34 PDT

Investigating

We are investigating an issue affecting access to the Pantheon Dashboard, Workflow, and/or the Platform API. Customers may experience errors such as [502 responses, degraded performance, or failed commands].

Our team is reviewing logs and metrics to determine the cause and implement a resolution. We’ll share additional updates here as the situation evolves.

We recommend postponing non-critical tasks involving the Dashboard or CLI until the issue is resolved.

If you are unable to access the Dashboard and need urgent support, please contact helpdesk@pantheon.io for support.
Posted Mar 28, 2026 - 05:41 PDT
This incident affected: Dashboard, Workflow Operations, and Terminus Operations.