Changes reset for on-server-development
Incident Report for Pantheon Operations
Postmortem

As part of our continuous efforts to harden our platform's security, a conflict in disparate systems arose which caused an error in our code synchronization utility. This error caused uncommitted (unsaved) on-server-development work to be reset to its last saved state for some number of sites.

We recommend users of on-server-development (aka SFTP mode) commit their work early and often to insure the data resides in multiple locations and is included in our automated backups.

We regret the loss this has caused our on-server-development customers. We will be reviewing our processes to identify ways we can prevent this from occurring in the future. If you have written files since 0700 UTC Friday and believe you are still experiencing this issue, please do not hesitate to open a support ticket.

Posted Mar 08, 2019 - 13:11 PST

Resolved
A platform issue caused uncommitted changes on development environments in SFTP mode to be reset to the last committed state.
Posted Mar 07, 2019 - 10:00 PST