Degraded Workflows
Incident Report for Pantheon Operations
Resolved
This incident has been resolved. As evidenced by the successful results, the implemented fix has proven to be effective in resolving the issue.
Posted Mar 17, 2023 - 15:57 PDT
Monitoring
Our engineering team has deployed a fix for the issue, and we are seeing successful results. We are currently monitoring the platform to ensure that everything is running smoothly.

If you're experiencing any ongoing issues, please don't hesitate to reach out to our support team for assistance.
Posted Mar 17, 2023 - 14:56 PDT
Update
After further investigation, we have determined that a specific subset of Drupal sites that had a code sync or deployment between 13:00-16:00 UTC on 2023-03-17 have been impacted by a bug. This bug resulted in an issue with some environments accessing files within their code directory. This issue caused cascading failures on our platform when deploying new code to environments.

We would like to assure you that this problem has not affected the entire platform, and the files are not lost but are currently inaccessible to the affected sites. If you suspect that your site has been affected, we encourage you to contact us via chat or by submitting a ticket, so that we can investigate the issue further.

Thank you for your understanding and patience as we work diligently to resolve this issue.
Posted Mar 17, 2023 - 13:53 PDT
Investigating
We are currently conducting a more thorough investigation of the issue since the initial solution seems to have been ineffective.
Posted Mar 17, 2023 - 10:52 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2023 - 09:02 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2023 - 08:18 PDT
Investigating
Our monitoring has detected elevated errors for some workflows, which may result in failed code deployment, backup restore, and creation of Multidev environments.
Posted Mar 17, 2023 - 07:56 PDT
This incident affected: Workflow Operations.