Dashboard Performance and Terminus-related Issues

Incident Report for Pantheon Operations

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 10:56 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 09, 2026 - 10:15 PST

Investigating

We are currently observing reduced performance affecting Dashboard loading, Terminus-related workflows, and some frontend site builds. Our Engineering team is actively investigating the issue and working to restore normal functionality as quickly as possible.
We understand this may impact your workflow and appreciate your patience while we work toward resolution.

Need Immediate Assistance?
If you require urgent support during this time:

General urgent concerns: Please submit a support ticket or use live chat.
If the Dashboard is inaccessible: Contact us at helpdesk@pantheon.io.
Posted Feb 09, 2026 - 09:31 PST
This incident affected: Dashboard, Workflow Operations, Terminus Operations, and Front-End Sites (Beta).