Dashboard Performance Issues

Incident Report for Pantheon Operations

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2026 - 15:03 PDT

Update

Investigation into the Pantheon Dashboard performance degradation is ongoing.
For critical support outside the dashboard interface, email helpdesk@pantheon.io immediately.

Next update: Between 30 minutes and 3 hours.
Posted Jul 10, 2026 - 10:57 PDT

Investigating

We are investigating reports of slow load times and degraded performance within the Pantheon Dashboard.
Traffic to live sites is routing normally and is not impacted by this event.

Our Engineering team is actively working to identify the root cause and restore full Dashboard functionality.
If you are unable to access the Dashboard to submit a ticket, please email us directly at helpdesk@pantheon.io for critical, time-sensitive deployments.

Next update: 30 minutes.
Posted Jul 10, 2026 - 09:33 PDT
This incident affects: Dashboard.