Degraded Git Operations And Deployment Workflows

Incident Report for Pantheon Operations

Update

Thank you for your patience and understanding. We are still continuing to investigate this issue.

We will provide the next update as soon as more information becomes available.
Posted Sep 15, 2025 - 23:48 PDT

Update

We are still continuing to investigate this issue.

We will provide another update as soon as further information becomes available.
Posted Sep 15, 2025 - 17:18 PDT

Update

We are continuing to investigate this issue.
Posted Sep 15, 2025 - 15:06 PDT

Investigating

We are currently investigating degraded performance or failures in certain platform workflows, such as pushing code via Git or committing code via the Dashboard, as well as deploying code to environments. This may affect your ability to push code, create environments, apply upstream updates, use Integrated Composer, or deploy code to environments.

Our engineers are actively triaging the issue and working to implement a fix. We’ll post progress updates regularly on this page.

We recommend pausing the deploying of new code to environments until the issue is resolved, at least if you experience issues. If you have any questions, please contact Pantheon Support.
Posted Sep 15, 2025 - 14:09 PDT
This incident affects: Workflow Operations and Git.