Most products have recovered and performance is normalizing.
Our engineering team is actively validating a few remaining product impacts. For urgent assistance or Dashboard access issues, please contact helpdesk@pantheon.io.
Posted Sep 01, 2026 - 10:40 PDT
Update
Telemetry graphs continue to show steady performance recovery across all impacted services. We are adjusting component statuses to Degraded Performance and actively monitoring systems as they normalize.
We have identified the root cause of the issue and are actively applying a fix. Telemetry is showing performance improvements across the Dashboard and affected sites.
If the Dashboard remains inaccessible and you require immediate assistance, please email us directly at helpdesk@pantheon.io. We will share another update shortly as services continue to recover.
Posted Sep 01, 2026 - 09:20 PDT
Update
Our investigation indicates that accessibility and performance issues are affecting a subset of hosted sites in addition to the Dashboard. We are treating this as a critical incident, and our engineering team is actively working to isolate the cause and restore service.
If you require immediate assistance and the Dashboard is inaccessible, please email us directly at helpdesk@pantheon.io. Thank you for your patience while we work to resolve this.
Posted Sep 01, 2026 - 08:56 PDT
Update
Our team is continuing its investigation into the degraded performance affecting the Dashboard interface.
In addition, recent telemetry shows that a small subset of hosted sites is also experiencing performance degradation. We are actively working to mitigate the impact and restore full functionality.
Posted Sep 01, 2026 - 08:38 PDT
Investigating
Our Engineering team is currently investigating reports of degraded performance affecting the Dashboard interface. A subset of users may experience slow page loading times or intermittent issues opening site environments. Live hosted sites and environment uptime remain fully operational and unaffected.
We are actively working to identify the root cause and restore normal performance as quickly as possible.
Need Immediate Assistance? • General concerns: Open a chat with our support bot and request to open a ticket for urgent cases. • If the Dashboard is inaccessible: Email us directly at helpdesk@pantheon.io.
We will provide another update within 30–60 minutes, or as soon as new information becomes available. Thank you for your patience.
Posted Sep 01, 2026 - 08:14 PDT
This incident affects: Customer Sites, Dashboard, Global CDN, Spinup Operations, Workflow Operations, Terminus Operations, Site Certificate Provisioning, Billing Operations, Autopilot, Git, Front-End Sites (Beta), and Content Publisher (Public Preview).