We will post another update in 3 hours or once a major update is available.
Posted Mar 27, 2026 - 01:27 PDT
Update
We are continuing to investigate the issue. Thank you for your patience and understanding.
Posted Mar 26, 2026 - 19:15 PDT
Update
We are continuing to work on a fix for this issue with the Dashboard and Terminus-related workflows.
We will share another update in 2 to 3 hours, or as soon as more information becomes available.
Posted Mar 26, 2026 - 15:54 PDT
Update
Our Engineering team is actively investigating the issue.
We will provide another update within the next 2-3 hours or sooner if new information becomes available. Thank you for your continued patience and understanding.
Posted Mar 26, 2026 - 11:11 PDT
Update
We are continuing to investigate the issue affecting Dashboard performance and Terminus workflows.
If you're experiencing any related issues, please reach out to Support via chat or ticket, and our team will investigate immediately.
We will provide another update within the next 30 minutes to an hour or as soon as more details become available.
Posted Mar 26, 2026 - 09:15 PDT
Update
Our team is still actively investigating the issue. Thank you for your patience.
Posted Mar 26, 2026 - 07:36 PDT
Update
We are continuing to investigate this issue.
Posted Mar 26, 2026 - 06:18 PDT
Investigating
We're currently investigating an issue affecting the loading of the Dashboard and Terminus-related workflows.
We apologize for any inconvenience this has caused.
If you're experiencing an urgent issue, please contact support at helpdesk@pantheon.io
Posted Mar 26, 2026 - 05:22 PDT
This incident affects: Dashboard and Terminus Operations.