Dashboard Login Issues

Incident Report for Pantheon Operations

Resolved

This incident has been resolved. Google login option is now working as expected

Thank you for your patience.
Posted Jul 27, 2026 - 04:49 PDT

Monitoring

A fix has been deployed, and the initial Dashboard login tests reflect positive results. Our team is closely monitoring.

We will provide a final update once the resolution is verified.

If you continue to experience the same issue, please contact us directly at helpdesk@pantheon.io.
Posted Jul 27, 2026 - 03:09 PDT

Update

We’re actively investigating the issue and will keep you updated.

For urgent support, please contact helpdesk@pantheon.io.
Posted Jul 27, 2026 - 01:38 PDT

Investigating

We are currently experiencing an issue with the "Connect to Google" login option on the Pantheon Dashboard. All live sites remain fully operational and unaffected.

Our engineering team is actively working to identify the root cause and implement a resolution. If you need immediate assistance, please contact us by email at helpdesk@pantheon.io.

We will provide our next update as soon as more information becomes available.
Posted Jul 27, 2026 - 00:33 PDT
This incident affected: Dashboard.