We are continuing to monitor traffic patterns and adapt network-level mitigations in response.
Posted Jul 21, 2026 - 06:43 PDT
Update
We can observe our mitigations denying an increasing volume of requests and are continuing to gather data to enhance our response.
We will provide an update Tuesday morning.
Posted Jul 20, 2026 - 15:20 PDT
Monitoring
Summary On July 17, 2026, the WordPress security team disclosed two chained vulnerabilities in WordPress core, publicly referred to as "wp2shell":
- CVE-2026-60137 — a SQL injection issue in WordPress core (WP_Query / author__not_in). - CVE-2026-63030 — a REST API batch-route confusion issue which, chained with the above, can lead to unauthenticated remote code execution.
Who is affected This affects specific versions of WordPress core:
- 6.9.x — affected by both issues (RCE-capable). Patched in 6.9.6. - 7.0.x — affected by both issues (RCE-capable). Patched in 7.0.2. - 6.8.x — affected by the SQL injection issue only (not the full RCE chain). Patched in 6.8.6.
Sites already on 6.8.6 / 6.9.6 / 7.0.2 or later, or on versions prior to 6.8, are not affected by this chain.
Why it matters Chained together, these vulnerabilities can allow an unauthenticated attacker to execute code against a vulnerable site.
Pantheon’s immutable containers prevent the deployment of webshells, bitcoin miners, or other exploits that leverage a downloaded payload in production environments. However, SQL Injection can still be used to deface or hijack sites.
Because working exploits are publicly available, we expect attack volume to rise.
What you should do — action required Update WordPress core to a patched version as soon as possible — 7.0.2, 6.9.6, or 6.8.6 depending on your branch — from your Pantheon Dashboard or via Terminus. Updating core is the definitive fix. See the WordPress 7.0.2 Security Release note: https://docs.pantheon.io/release-notes/2026/07/wordpress-7-0-2
What Pantheon is doing - We are actively monitoring platform traffic for exploitation attempts targeting the affected REST API endpoint. - We have observed sites being probed for vulnerability and have actively mitigated against sources of scripted activity already. - We are deploying targeted mitigations at the network level to programmatically prevent exploit attacks across the platform and can confirm that released exploit code is being mitigated. - Will update this post with more information as those efforts progress.