Global CDN Outage
Incident Report for Pantheon Operations
Postmortem

On May 7th, 2020, we observed a brief outage in our Global CDN. The event started at 5:06pm UTC and lasted for 4 minutes. During that time the ability of the platform to deliver content was severely downgraded for some sites. Approximately 10% sites were impacted, most for a few seconds and some for up to the 4 minute duration of the incident. We have since worked diligently with our provider to understand what happened and make sure the right mitigation would be put in place at the CDN level to protect the platform from any future similar outage. Our provider has shared deep technical details of what happened under NDA.

  • Changes have been made to the system involved to protect against any future occurrences
  • Additional detection and notification layers have been put in place.

Finally, we want to note that our CDN provider has historically been extremely reliable. This is the only significant edge disruption we have encountered in the last 24 months.

Posted May 13, 2020 - 10:11 PDT

Resolved
This incident has been resolved.
Posted May 07, 2020 - 11:46 PDT
Monitoring
We observed a brief outage in our Global CDN. All sites have recovered. We are monitoring.
Posted May 07, 2020 - 11:15 PDT
This incident affected: Global CDN.