Degraded Dashboard Performance

Incident Report for Pantheon Operations

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:11 PST

Monitoring

The fix has been successfully deployed. We are currently monitoring service stability.
Posted Nov 18, 2025 - 14:31 PST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 13:18 PST

Investigating

Our internal monitoring has been alerted to issues regarding Dashboard performance.
The Engineering team is currently investigating this and will post more updates here as soon as we have more information to share.

We apologize for any inconvenience this has caused.
We appreciate your understanding and patience during this process.

If you require urgent support, please open a ticket or chat. If you are unable to access the dashboard, you may also contact us via email. helpdesk@pantheon.io
Posted Nov 18, 2025 - 12:09 PST
This incident affected: Dashboard.