This incident has been resolved. You can now safely proceed with deployments.
Posted Apr 18, 2026 - 19:00 PDT
Monitoring
A fix has already been implemented, and we are monitoring the results.
We recommend doing a hard refresh before triggering new workflows on the dashboard.
Posted Apr 18, 2026 - 18:01 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 18, 2026 - 17:25 PDT
Update
We are continuing to investigate this issue.
Posted Apr 18, 2026 - 17:04 PDT
Investigating
We are currently investigating degraded performance in the deployment workflows from the Test to the Live environment. We have identified a high-risk configuration in the current deployment process that may lead to unintended data and file loss within the live environment.
Our engineers are actively triaging the issue and working to implement a fix. We'll post progress updates regularly on this page.
We recommend pausing the use of deploy to Live until the issue is resolved.