A fix has been implemented, and users should now see visible performance improvements when loading the Dashboard.
Our Engineering team is closely monitoring the environment to ensure stability and verify that the issue is fully resolved. We will provide a final update once the resolution is confirmed. If you continue to experience any issues, please contact us at helpdesk@pantheon.io.
Posted May 13, 2026 - 14:51 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 13, 2026 - 14:13 PDT
Update
Engineering continues to investigate the reported performance delays within the Dashboard.
We would like to clarify that all services remain operational and customers should not experience downtime; the impact is strictly limited to Dashboard's page responsiveness.
Our next update will be provided in approximately 2–3 hours, or sooner as information becomes available. If you require urgent assistance, please contact helpdesk@pantheon.io.
Posted May 13, 2026 - 12:22 PDT
Update
Our Engineering team is continuing to investigate the cause of the Dashboard performance issues.
Client sites remain unaffected, and we are working to restore full functionality as quickly as possible. For urgent assistance or if the Dashboard is inaccessible, please contact us at helpdesk@pantheon.io.
Posted May 13, 2026 - 10:11 PDT
Investigating
We are currently observing reduced performance affecting Dashboard loading, though live sites remain unaffected.
Our Engineering team is actively investigating the issue and working to restore normal functionality as quickly as possible. We understand this may impact your workflow and appreciate your patience while we work toward a resolution.
If you require immediate assistance for general urgent concerns, please submit a support ticket or use live chat. In the event the Dashboard is inaccessible, please contact us directly at helpdesk@pantheon.io.